Workflow usage amounts are incorrectly calculated

Incident Report for Vercel

Resolved

The usage tracking system is fully recovered.
Posted May 15, 2026 - 16:18 UTC

Monitoring

The team fixed the incorrect calculations. We are resuming usage tracking and continuing to monitor.
Posted May 15, 2026 - 15:39 UTC

Update

We are continuing to work on the fix. Usage tracking for Workflow Storage remains paused. The incorrect calculations will not be charged.
Posted May 15, 2026 - 13:40 UTC

Identified

The team has identified the source of the incorrect usage data calculations and has paused usage tracking while a fix is being prepared.
Posted May 15, 2026 - 11:37 UTC

Investigating

Workflow Storage Retention and Workflow Storage Writes are being incorrectly calculated in usage data. The team is investigating and working to resolve the discrepancy.
Posted May 15, 2026 - 10:34 UTC
This incident affected: Workflow.